Game hubs partially degraded
Resolved
Mar 19, 2026 at 04:24pm UTC
The issue has been resolved and all services are now fully restored. We monitor the situation.
Affected services
Updated
Mar 19, 2026 at 04:00pm UTC
Game hubs are currently experiencing partial service degradation, which may result in slow performance or temporary unavailability for some players. Our team is working on a fix and service will be fully restored shortly.
Affected services
Updated
Jun 24, 2025 at 05:58pm UTC
The issue has been resolved and all services are now fully restored.
Affected services
Updated
Jun 24, 2025 at 05:42pm UTC
Game hubs are currently experiencing partial service degradation, which may result in slow performance or temporary unavailability for some players. Our team is working on a fix and service will be fully restored shortly.
Affected services
Updated
Jun 24, 2025 at 05:18pm UTC
The issue has been resolved and all services are now fully restored.
Affected services
Created
Jun 24, 2025 at 05:05pm UTC
Game hubs are currently experiencing partial service degradation, which may result in slow performance or temporary unavailability for some players. Our team is working on a fix and service will be fully restored shortly.
Affected services