Back to overview
Degraded

Dashboard is partially degraded

Jun 12 at 12:15pm CST
Affected services
Dashboard

Resolved
Jun 12 at 01:02pm CST

The issue has been resolved and all services are now fully restored.

Created
Jun 12 at 12:15pm CST

Dashboard is experiencing partial degradation, causing slow loading or temporary unavailability for some users. We are investigating the issue and working to restore service shortly.