Back to overview
Degraded
Game hubs partially degraded
May 20 at 09:15am CST
Affected services
Game Hubs
Resolved
May 20 at 09:45am CST
The issue has been resolved and all services are now fully restored.
Affected services
Game Hubs
Created
May 20 at 09:15am CST
Game hubs are currently experiencing partial service degradation, which may result in slow performance or temporary unavailability for some players. Our team is working on a fix and service will be fully restored shortly.
Affected services
Game Hubs